Adler/Barbour Troubleshooting (and Waeco 50, 80, and 90 series)

By: Jacob

These units are simple to troubleshoot, but if for some reason you donít feel comfortable, or you donít have the proper equipment, we have a large distributor/dealer network to handle issues in the field. Go to Cruisair.com and find a dealer. Choose your state/location. WHAT IS ON THE WEBSITE IS THE DISTRIBUTORS. THEY MAY BE IN ANOTHER STATE OR A COUPLE HUNDRED MILES AWAY. HOWEVER, IF YOU CONTACT THEM, THEY CAN REFER YOU TO A DEALER LOCATED NEAR YOUR BOAT.

 

This isa simple troubleshooting guide Iíve made up myself to help when your system is not performing correctly. These are just some scenarios I encounter everyday, and figured Iíd put them in this simple, laymanís terms troubleshooting guide. Before you start, there are a couple things you may need to identify. The Coldmachines produced now contain two PC boards on the actual unit. The front one (the one including the LED troubleshooting) will be referred to as just the PC BOARD. The electronic board mounted to the compressor itself is called the DANFOSS MODULE. If your unit only has one board, and no board w/ the LED light, then all you have is the DANFOSS MODULE. Please note, that there is no way to bypass this board to jump the compressor, and DANFOSS HAS NEVER RELEASED ANY INFORMATION TO DOMETIC ON HOW TO TROUBLESHOOT THIS MODULE, OR A SCHEMATIC FOR THE BOARD INSIDE. The compressor is actually a 3 phase AC compressor. If you try and bypass the module, and run 12VDC directly to the compressor IT WILL RUIN THE COMPRESSOR.

 

If your unit does not have the two PC boards, then there will be a portion at the end of this for your unit.

BY LAW, UNLESS YOU ARE EPA CERTIFIED, YOU CANNOT HANDLE OR WORK WITH ANY KIND OF REFRIGERANT. EVEN THOUGH R134A IS SOLD AT WAL-MART AND AUTO PARTS STORES, YOU ARE NOT ABLE TO HANDLE IT WITH OUT AN EPA CERTIFICATION. DOMETIC CAN NOT ASSIST IN HELPING CHARGE EQUIPMENT WITH SOMEBODY WHO IS NOT EPA CERTIFIED, BECAUSE WE CAN BE HELD LIABLE. REFRIGERANT, IF NOT HANDLED CORRECTLY CAN NOT ONLY CAUSE HARM TO THE OZONE LAYER, BUT CAN CAUSE BODILY HARM, AND LACK OF OXYGEN IF YOU ARE IN A CONFINED SPACE.

Nothing will Start and no LED blinks

1.)    Make sure you are getting the proper voltage at the input of the unit. AT THE INPUT OF THE UNIT, NOT THE BATTERIES OR THE BREAKER. Be sure that your connections are good, free of corrosion, and are not loose or have fallen out.

2.)    If so, check to see if youíre getting voltage through the front PC Board to the top two terminals on your Danfoss module (Skip this step, if your unit does not have the front PC Board). If so, go to next step. If not check all the fuses on your front PC Board. The 15a is the main fuse for everything, and the five amp is for the fan/pump circuit. There should be another Ĺa fuse on the back side of that PC board, thatís in line with the thermostat circuit. Older units did not have this.

3.)    If you are getting the same voltage through the PC Board to the module, the next thing to do is to bypass the thermostat circuit. To do this, you will need to remove two wires from your Danfoss module, T and C. It will be a brown and black wire. Once these two wires are removed, you will need to make a jumper wire, with two female push on terminals. Put the jumper wire on terminals T and C to bridge the two (you can also use a pair of needle nose pliers or what ever you have laying around to make a connection, there is no voltage present to hurt anything). If the unit still does not start or try to start, then you will need to replace the Danfoss module. If so, proceed to next step.

4.)    If the compressor does start, then it may be the phone cord end on the tstat, the phone cord connection on the board, or the speed resistor on the inside of the actual tstat housing. To test the speed resistor, unplug it, and ohm out across the pins on it. There are three different ones we use, and it should read across either 270, 680, or 1500. These are there to make the compressor run at the proper speed for whatever plate you have.

5.)    If that checks okay, there is really no way to test the phone cord connections with out fancy equipment. Save your self time and money and just bypass it. Cut the phone cord off the end of the wire coming from the tstat, install some female push ons, and plug them onto terminals C and T. The tstat will work the exact same as it did before.

 

Now Iíll just go over the different series of blinks you may get if an electronic problem arises. The module has built in troubleshooting capabilities, that you can use a 10ma LED bulb to determine what the module thinks is wrong. The light will blink a series of times, and pause, then continue. This makes these units very simple to troubleshoot. On the newer units, we incorporated this into the front PC board. IF YOUR UNIT DOES NOT HAVE THIS BUILT IN FEATURE, YOU CAN INSTALL YOUR OWN LED ONTO THE MODULE. One end of the LED goes to terminal ďDĒ on the module, and the other will need to be piggy backed onto the positive fan terminal on the module.

 

One blink Ė Low Voltage

 

1.)    99% OF TIME WHEN THE MODULE BLINKS THIS, IT IS DEFINITELY LOW VOLTAGE. I have never seen a scenario where this is not the case.

2.)    If youíre getting this code, then most likely your unit is trying to start, there will be a slight shutter, then it will stop, and continue to do this.

3.)    Watch the voltage AT THE INPUT OF THE UNIT AS ITíS STARTING AND STOPPING. You will see a significant drop in voltage. The low voltage cut off is 10.4VDC, but you will probably never see it get this low on your meter because of buffers etc installed in the meter. If you see a drop of over 1VDC you have a problem. You will need to track down the boats wiring, find your loose connection/corrosion thatís causing the high resistance. You may even have a weak cell in the battery.

4.)    If you feel the voltage is sufficient, then the only other problem may be the Danfoss module. However, I have never seen the module fail like this, and itís an expensive part to replace, for it continue to do the same thing.

ANOTHER THING IíVE FOUND WITH WORKING WITH THESE, IS IF THE UNIT GETS LOW VOLTAGE FOR A PERIOD OF TIME, THE MODULE FAILS. I HAVENíT BEEN ABLE TO GET DANFOSS TO SAY YE OR NE IF THE LOW VOLTAGE CAUSED IT, BUT THATíS WHAT USUALLY HAPPENS.

 

Two blinks Ė Fan overcurrent Protection Cut Out

 

1.)    The module has a feature that if the fan draws more than (1a older modules, .5a newer modules) it will cut everything out. This is simple to troubleshoot.

2.)    Disconnect the fan terminal from the PC Board (newer) or from terminal F on the Danfoss module. If the unit still blinks, replace the module. If not replace the fan.

 

Three blinks Ė Motor Start Error

 

1.)    If the compressor cannot achieve a certain RPM in a given time, the module will kick it out.

2.)    Three things will cause this: pressures have not equalized yet, unit has been overcharged, or the Danfoss module is defective.

3.)    One, leave the unit off for fifteen minutes, if it starts, then your unit had short cycled for some reason. No need to worry unless it does it all the time.

4.)    Two, unit was charged recently, and has been overcharged. If the unit is overcharged, the compressor will not be able to get up to speed because it has been overloaded. Get somebody on board who is EPA CERTIFIED, to recover refrigerant according by law and EPA standards.

5.)    If none of this is the case, then replace the Danfoss module, please remember, there is no way to determine weather itís the module or the compressor, other than replacing. However, with all the Danfoss compressors I work with every day, Iíve only seen a couple fail.

 

Four and Five blinks Ė

 

1.)    I hardly ever see these. Ö Four blinks youíll have to replace the module.

2.)    5 blinks mean lack of ventilation. If the unit runs for a while then flashes this, then itís a lack of ventilation. Unit needs atleast 100 sq inches of air space to operate correctly. It also will not work above 115 degrees with out the water cooled option.

3.)    If the unit flashes 5 times immediately, replace the module.

 

 

Everything runs, but my unit is not cooling, or there is minimal coolingÖ

 

1.)    First, check your condenser coil (radiator beside the compressor), and make sure that itís clean and free of any kind of debris.

2.)    If all that checks okay, call a technician on board. There is most likely a leak in the system. The leak needs to be found, fixed, and recharged. Once again, MUST BE EPA CERTIFIED.

 

 

Danfoss Compressors

 

Waeco and Adler/Barbour have always used Danfoss compressors, however, they have changed over the years. Rather than get all technical and confusing, there were pretty much two different types of compressors, 3 pin and 4 pin, with 3 being the newest, and 4 the oldest. You will need to remove the module to see how many pins your compressor has. There really is no way to bypass the module, to hard start the compressor. However, you can ohm the compressor pins out, to see if you may have an open or shorted winding. The three pin compressors, you should have 2.3-2.5 ohms between all three pins, and no continuity to ground. On the four pin compressors, ohm readings should be .2-.4, .2-.4, and 2.5-4.5 and no shorts to ground.

 

Unit drawing high amps

 

Typically, depending on the conditions, your unit will run anywhere from 4-6 amps. That depends on how much you have in the fridge, how hot it is that day, ventilation, clean coils, insulation etc. If your unit starts drawing higher amperage it could be a few different things. First, check the voltage at the input of the unit. The lower voltage gets, the higher the amp draw. Second, check your condenser coil to be sure itís clean. If itís dirty, and has poor airflow, it cannot condense and disperse the heat like itís designed to do. Another is the unit has recently been overcharged. GET A TECH ON BOARD. Last, it may indicate your compressor is going bad, but like I said before, itís very rare I see these things fail.

 

Unit blows fuses constantly

 

If your unit is blowing fuses as soon as it tries to start, itís usually the compressor or the Danfoss module. Disconnect the module plug from the compressor, leaving everything else wired like normal and try to restart. If it does not blow the fuse, then the compressor is bad. If so, then the module is bad. (Note, This is not from Danfoss, itís just what makes sense, and Iíve told people to do this on numerous occasions and it seems to work).

 

If your unit is older, and doesnít have the PC Board

 

Basically, everything is still the same, you just donít have the convenience of having the LED already there. Wonít start, bypass tstat like above. Trying to start, monitor voltage, unplug fan, then replace moduleÖ. Follow the same steps as above to find out whatís going on.

 

 

THESE ARE THE MOST COMMON PROBLEMS, IíM SURE IíLL THINK OF SOME MORE STUFF LATER. IF NOT EXPLAINED CLEARLY, OR YOU STILL HAVE QUESTIONS, CONTACT THE SERVICE DEPARTMENT AT 800-234-8778.